Typo on

Typo on "my buddies" page.

Site Ideas

Cookies help us deliver our Services. By using our Services or clicking I agree, you agree to our use of cookies. Learn More.

d

Brooklyn, NY

Joined
19 May 04
Moves
14088
30 Mar 05

It says: convientint

RHP Code Monkey

RHP HQ

Joined
21 Feb 01
Moves
2419
30 Mar 05

Fixed about a month ago on my development machine, but a new major release of all the code has not been uploaded since then...so that glaring typo goes uncorrected. But since someone else has noticed it, I better fix it now...

-Russ

d

Brooklyn, NY

Joined
19 May 04
Moves
14088
31 Mar 05

Thanks :-)

Nearing 250000...!

Joined
23 Mar 04
Moves
250417
31 Mar 05
2 edits

Another sort of typo; when I have only 1 game waiting, it says '1 games waiting'. That's silly...!

Why not add an:

if (gamesWaiting == 1)
{
gamesWaitingText = (gamesWaiting + " game waiting" ) ;
}
else
{
gamesWaitingText = (gamesWaiting + " games waiting" ) ;
}

...or something...

l

Milton Keynes, UK

Joined
28 Jul 04
Moves
80236
04 Apr 05
2 edits

or:

gamesWaitingText = (gamesWaiting + " game" ) ;

if (gamesWaiting != 1)
{
gamesWaitingText = gamesWaitingText + "s";
}

gamesWaitingText = (gamesWaiting + " waiting" ) ;

😉

A
Lazy Sod

Everywhere

Joined
12 Oct 04
Moves
8623
06 Apr 05
1 edit

waste of code really:

gamesWaitingText = (" Games Waiting : " + gamesWaiting ) ;

EDIT: much shorter and much neater.



r

Uk

Joined
20 Mar 05
Moves
19460
06 Apr 05

all ur codes look c'ish so i would use t'nry operator (cos Im lazy typist):

gamesWaitingText = (gamesWaiting != 1) ? (gamesWaiting + "games waiting"😉 : (gamesWaiting + " game waiting"😉;

r

Uk

Joined
20 Mar 05
Moves
19460
06 Apr 05

Originally posted by redbaron101
all ur codes look c'ish so i would use t'nry operator (cos Im lazy typist):

gamesWaitingText = (gamesWaiting != 1) ? (gamesWaiting + "games waiting"😉 : (gamesWaiting + " game waiting"😉;
b@*&^@! smilies!!

gamesWaitingText = ( gamesWaiting != 1 ) ? ( gamesWaiting + " games waiting" ) : ( gamesWaiting + " game waiting" ) ;

Nearing 250000...!

Joined
23 Mar 04
Moves
250417
06 Apr 05

Hmm, that's better coding...

M
me, not you

CaNaDa

Joined
25 Nov 04
Moves
46658
06 Apr 05
1 edit

wouldn't it be just easier if he just put the s in () ?

Game(s) Waiting.. no code needed.. just uglier

m

Dhaka

Joined
08 Oct 04
Moves
3885
06 Apr 05

Originally posted by redbaron101
b@*&^@! smilies!!

gamesWaitingText = ( gamesWaiting != 1 ) ? ( gamesWaiting + " games waiting" ) : ( gamesWaiting + " game waiting" ) ;
A shorter one:

gamesWaitingText = ( gamesWaiting != 1 ) ? ( gamesWaiting + " games waiting" ) : ( 1+ " game waiting" ) ;


A smarter one:

gamesWaitingText = ( gamesWaiting != 0)?((( gamesWaiting != 1 ) ? ( gamesWaiting + " games waiting" ) : ( 1+ " game waiting" ))🙁"no games waiting);

Nearing 250000...!

Joined
23 Mar 04
Moves
250417
11 Apr 05

The same should apply with the messages indicator (or how one calls it). When I have only one unread message, it refers to it as 'messages'.

Nearing 250000...!

Joined
23 Mar 04
Moves
250417
22 Apr 05

And the same should apply with the reccomendation indicator (or how one calls it). When I have only one recommendation, it refers to it as 'recommendations'.