Technology Forum

Technology Forum

  1. Subscribersonhouse
    Fast and Curious
    slatington, pa, usa
    Joined
    28 Dec '04
    Moves
    52874
    19 Aug '19 22:16
    I tried Touchpad blocker but after a while on my win 10 HP laptop it would stop blocking even though a window comes up saying touchpad blocked but moving around on touchpad shows it still controls the arrow. The only way out was to uninstall it and redownload another copy.
    That has happened about 4 times now so looking for something more stable.
    I tried the disable bit in devices but I hit disable and hit ok and such to no effect, this was after I uninstalled blocker. It still runs even if I hit disable.
    I use USB mouse and cannot stand the stupid touchpad, just typing this post the magnification has changed 4 times, bigger or smaller, no rhyme or reason, total random depending on just how I touch the damn pad.
  2. SubscriberKewpie
    since 1-Feb-07
    Joined
    20 Jan '09
    Moves
    329431
    21 Aug '19 07:251 edit
    @sonhouse

    https://itstillworks.com/disable-touchpad-hp-laptop-12667.html

    and if that doesn't work with your model, Mr Google will give you several other options if you search for "disable touchpad hp laptop"
  3. Subscribersonhouse
    Fast and Curious
    slatington, pa, usa
    Joined
    28 Dec '04
    Moves
    52874
    21 Aug '19 14:50
    @kewpie said
    @sonhouse

    https://itstillworks.com/disable-touchpad-hp-laptop-12667.html

    and if that doesn't work with your model, Mr Google will give you several other options if you search for "disable touchpad hp laptop"
    Two things from that post, you have to hold the little off button for 5 seconds, didn't know that. And didn't think about removing drivers. Thanks.
    Touchpads are a pain in the ass, just get CLOSE to the dam thing while typing and boing, 230% magnification or 90%.
    It's weird disabling it in device manager doesn't work, hit the disable button and hit ok, which is supposed to that, but still works.
    I'll try the button thing when I get off work. Thanks.
  4. Subscribersonhouse
    Fast and Curious
    slatington, pa, usa
    Joined
    28 Dec '04
    Moves
    52874
    22 Aug '19 01:12
    @kewpie said
    @sonhouse

    https://itstillworks.com/disable-touchpad-hp-laptop-12667.html

    and if that doesn't work with your model, Mr Google will give you several other options if you search for "disable touchpad hp laptop"
    The 5 second thing didn't do it but what I missed was the 'Apply' button, when I did that the light saying TP was dead finally came on without resorting to that stupid Touchpad Blocker.
  5. Standard memberKellyJay
    Walk your Faith
    USA
    Joined
    24 May '04
    Moves
    150521
    05 Oct '19 18:42
    @sonhouse said
    I tried Touchpad blocker but after a while on my win 10 HP laptop it would stop blocking even though a window comes up saying touchpad blocked but moving around on touchpad shows it still controls the arrow. The only way out was to uninstall it and redownload another copy.
    That has happened about 4 times now so looking for something more stable.
    I tried the disable bit in ...[text shortened]... mes, bigger or smaller, no rhyme or reason, total random depending on just how I touch the damn pad.
    I turn off the touch pad and if there buttons at the bottom of the key pad they are toast too. I keep hitting them when typing.
  6. Subscribersonhouse
    Fast and Curious
    slatington, pa, usa
    Joined
    28 Dec '04
    Moves
    52874
    14 Oct '19 20:04
    @KellyJay
    I gave up on the pad blocker, so when the OS gets updated and restarted, I go into settings and find the touchpad window and hit disable, it turns out you have to also hit apply, which I didn't do the first time but now can do it in my sleep.
    I would like to kill it permanently but have to live with this method.
Back to Top